タグ別アーカイブ: rubygems-update

Rails向けプリローダ spring1.0 で Rubygemsのバージョンアップが必要な件


rbenvでインストールしたrubyでRails向けプリローダのspringが1.0にメジャーアップしていたので、
使ってみたら、RubyGemsのバージョンが低いというWarningが出る。。。

Warning: You're using Rubygems 2.0.14 with Spring. Upgrade to at least Rubygems 2.1.0 and run `gem pristine --all` for better startup performance.
Version: 1.0.0

そこで、RubyGemsのアップデート方法を以下に書きます。(ずっとBundlerを使っていたので、急にRubyGems本体のアップデートとかやろうと思っても分からなかったので、、、)

アップデート手順

参考:
新しいgemのアップデート方法(rubygems-update)
本当有難うございます。まんまの手順でした。。

1.rubygems-updateをインストールする

% gem install rubygems-update

2.アップデート前確認

アップデート前にRubygemsのバージョンを確認しておく

% gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.0.14
  - RUBY VERSION: 2.0.0 (2013-11-22 patchlevel 353) [x86_64-darwin12.5.0]
省略

3.アップデート実行

% update_rubygems

4.アップデート後確認

% gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.1.11
  - RUBY VERSION: 2.0.0 (2013-11-22 patchlevel 353) [x86_64-darwin12.5.0]
省略