備忘録 Android @Overrideで大量エラーの対処


androidでeclipseを使用している時に新たなワークスペースでインポートするときなど、
「スーパークラスのメソッドをオーバーライドする必要があります」というエラーが大量発生した場合。

よく見ると@Overrideアノテーションのところでエラーとなっている。

なんてことはない、単純にJavaコンパイラーのバージョンが1.5の場合に発生するようです。。。

Javaコンパイラーを1.6以上にしてあげると解決。。

何でだろう、Android以外のプロジェクトでは1.5でも@Override使えていたような気がするんだが??
1.6からだったんだろうかーーーーー?

参考URL:http://techbooster.jpn.org/andriod/environment/6626/

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です